Siri Not Working on Bridge 2

Updated 4 days ago in [Troubleshooting]
3 on March 29, 2016

Hey there,

I got the new Philips hue bridge version 2. Everything seemed to be working fine except today Siri is not working any more.

It gives me this error:

“Another user already paired the HomeKit enabled bridge. Please ask the user to share his / her home kit settings in order for you to start using Siri voice control”

Any idea how to solve this?

  • Liked by
Reply
1 on March 29, 2016

Hey User1, 

I had the same issue and spent quite some time researching this issue. I found these solutions. Hope some of them will help you:

——————SOLUTION A———————-

http://labs.meethue.com/support/siri-homekit

——————SOLUTION B———————-

Go here first: http://www.developers.meethue.com/documentation/getting-started

Follow the instructions and make sure that you can turn a light off, exactly as they tell you to. This will ensure that you are communicating with the bridge from your computer and have permission to send commands.

Then, in the debugger under URL type:
http://<ip-address.of.the.bridge>/api/<username>/config

You should have the IP address and Username set up from the “Getting Started” that you just completed.

In the “Body,” copy and paste the following:

{
“homekit”: {
“factoryreset”: true
}
}

Click PUT.

It should return a “success” message.

Lastly, go into the Hue app, click on Settings > Siri Voice Control > Pair Bridge. It will instruct you to enter the code as if you’ve never done it before. You should then be able to see / select your scenes and lights for voice control.

——————SOLUTION C———————-

The error “another user already paired..” can be solved by a new command via the API Debug Tool of the Bridge

http://www.developers.meethue.com/content/bridge-already-paired-another-user-fix -needed
Post # 51

A short guide to use this tool:
http://www.developers.meethue.com/documentation/getting-started

After that I was able to set up the Siri-Function in the App of my iPhone. All lamps and Settings are retained

——————SOLUTION D———————-

1. Presuming your phone will be the main account for the HomeKit settings, start by resetting your HomeKit Configurations under Settings / Privacy / HomeKit

2. Using your phone, go to this link: http://www2.meethue.com/media/3173537/pressguidelines_homekitcompressed.pdf and follow the directions. You will need a third party app like Elgato Eve to set this up.

3. After you have successfully configured your lights, test to make sure all your Siri commands work (both rooms and scenes).

4. To share your HomeKit settings you will need to enter in your roommate or family member’s icloud account. NOTE: I tried to add my girlfriend’s account using her gmail account associated with her apple ID. That didn’t work. I had to use her @icloud.com email.

5. Once you’ve added it, the other person’s phone will say that they have been invited. They have to go to Settings / Homekit and accept the invitation.

6. It took me awhile to figure this out but this is important, your roommate/family member should download the Elgato Eve app and start it up. The settings should automatically have been added when it launches.

7. Your roommate / family member must go to Settings / Homekit. They will see that there is a local HOME account and also a shared HOME account. They must delete their local Home Account (not shared) so that only the shared one exists. Siri didn’t respond to commands on the shared account until I did that.

on January 26, 2017

I have the solution!  Tried everything else but this was the only thing that worked.

1) open the hue app > bridge > clear

2) sign out of iCloud.

3) sign in to iCloud but reset your iCloud Keychain (password then forgot code, then reset)

4) open the home app and let it run for approximately 30 minutes

5) a message at the bottom of the home app should appear asking if you want to reset HomeKit

6) hell yes!

7) set up the hue app and add the HomeKit as usual

Show more replies
  • Liked by
Reply
Cancel
0 4 days ago

What to do if siri is not working on iPhone?

  • Liked by
Reply
Cancel
Loading more replies