Warning: count(): Parameter must be an array or an object that implements Countable in /nfsmnt/hosting1_1/0/e/0ecee084-f359-4c8a-8196-cba638da0721/philipshue.com/web/wp-content/themes/forumengine-2/includes/front.php on line 707
Philips Hue Bridge Not Controlling All Lights Using Alexa Routine | Philips Hue Site

Philips Hue Bridge Not Controlling All Lights Using Alexa Routine

Updated on March 3, 2019 in [Hardware for Philips hue]
1 on February 22, 2019

We have a “Goodnight” routine set up in Amazon Alexa that is triggered by telling Alexa “Goodnight”.  It turns off 3 Hue bulbs (in 2 rooms), and turns off 4 Amazon Smart Plugs.  It also turns on our 2 Bedroom lights to 50% power and 2 Bathroom lights to 100%, all of which are Hue bulbs.  The Bedroom lights always work correctly, but it’s a hit-and-miss on the Bathroom lights.  Sometimes 1 comes on bright and 1 stays off.  Other times, one comes on at less than 100% power, and the other light stays off.  Sometimes, neither light comes on.  Both bulbs are within 10 feet of the Bedroom bulbs, so it’s NOT an issue with the bridge not being able to communicate with the bulbs.  Besides, Alexa will always turn them on when she’s told, and we can do it manually from the Hue app and the Alexa app.  We don’t want to manually turn things on or off when there’s a routine set up to do this!  That’s why we have routines!

So, is Alexa sending all of the Hue commands to the Philips bridge quicker than the bridge can process the commands?  Is the Alexa Skill for Philips Hue somehow broken?  Is the Hue website not able to keep up and is dropping the commands?  Something is broken here!!  And we thought we were making our home “smart”, but it’s looking REALLY stupid right now using the Philips Hue products.

Any help, including software updates, would be greatly appreciated!  Philips, are you listening?  Hint, hint.

Thanks!!

 

 
  • Liked by
Reply

0 on March 3, 2019

Apparently Philips Hue doesn’t bother to monitor this forum area, or they don’t have a clue what’s wrong with this configuration that’s supposed to work as created.  Since they don’t know what’s going on, chances are they’re also not going to be fixing it any time soon.  Considering how much each of these bulbs cost, not to mention the cost of the Hue bridge, wouldn’t ya think that they’d be a bit more interested in keeping their customers happy with software/hardware that actually works?  Just a thought.

OK, since Philips Hue hasn’t responded (nor has anyone else), and it doesn’t work any better now than what it did when I created the original post, I have a workaround.  This is NOT a fix, but it does appear to get around the limitations of the Philips Hue app, the Alexa Hue skill, the Hue bridge, the Hue lights, or the Hue cloud server.  Not for sure which is the culprit.  Maybe they all play a role in this.

Since I want to make sure that each of our smart plugs is also turned off before bedtime, they were included at the beginning of the “Goodnight” routine.  They NEVER fail to turn off!!  Assuming that there is a timing issue within the HUE cloud server, the Hue hub, or in the Hue bulbs, I moved a “turn off” command for each of the Amazon Smart Plugs before, after, and in between each of the commands for the Hue lights that I wanted to control within the routine.  No more problems with the Bathroom lights for about a week now.  Hmmm….

Philips, if you’re listening, does that give you another clue as to what the problem is?  And no, it’s not our Internet connection; we run 150 Mbps down and 25 Mbps up, at a minimum.

 

  • Liked by
Reply
Cancel
Loading more replies